早在几年前,谷歌就推荐在Android2.3版本以上使用HttpURLConnection,而在正式发布的 Android P 版本中,谷歌彻底取消了对Apache HTTPClient的支持,针对此更改,开发者该如何正确适配 Android P 。

Android 6.0 版本移除了对Apache HTTP客户端的支持。如果你的应用使用该客户端,并以 Android 2.3(API 级别为9)或更高版本为目标平台,请改用 HttpURLConnection 类。此API效率更高,能够通过透明压缩和响应缓存减少网络使用,并可最大限度降低耗电量。要继续使用 Apache HTTP API,须先在 build.gradle 文件中声明以下编译时依赖项。

android { 
    useLibrary 'org.apache.http.legacy' 
}

 

Remove org.apache.http.legacy from bootclasspath

从Android P开始,org.apache.http.legacy 库将从 bootclasspath 中删除。

 

(1). 修改对 TargetSdkVersion<P 的应用的影响

该修改对大多数 TargetSdkVersion<P 的应用都无影响,但是如果应用使用了系统 ClassLoader加载org.apache.http.*中的类时,将在Android P上发生 NoClassDefFoundError 失败,因为系统ClassLoader不再知道这些类。为了防止将来出现类似的问题,应用应该通过应用 ClassLoader 加载类,而不是直接访问系统ClassLoader。

方案一:不要使用非标准的 ClassLoader 。

方案二:应用可以自己添加依赖的 apache jar 包到工程 libs 目录规避该兼容性问题。

注意:对于最低 SDK为23或更低的应用程序,android:required="false"属性是必需的,因为在 API 等级低于24的设备上,org.apache.http.legacy 库不可用。(在这些设备上,Apache HTTP 类在 bootclasspath 上可用。)

 

(2). 修改对 TargetSdkVersion>=P 的应用的影响

对所有 TargetSdkVersion>=P 的应用,如果还是按照通过在 build.gradle 文件中声明依赖项。

想继续使用 Apache-http 接口,都会出现 Apache-http 接口找不到的异常。

需要在应用的 AndroidManifest.xml 文件中添加:

<uses-libraryandroid:name="org.apache.http.legacy"android:required="false"/>

 

最后,还是推荐使用 HttpURLConnection 替代 Apache-http。

 

 

发布评论
IT源码网

微信公众号号:IT虾米 (左侧二维码扫一扫)欢迎添加!

Layout的setWeightSum函数使用方法讲解
你是第一个吃螃蟹的人
发表评论

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。