前几天新建maven项目时,系统自动生成的POM文件第一行总是报错

org.apache.maven.archiver.MavenArchiver.getManifest(org.apache.maven.project.MavenProject, org.apache.maven.archiver.MavenArchiveConfiguration)

百思不得其解,明明是自动生成的怎么还会有错。在网上搜了一下,好多人都说这是由于maven的配置文件不是最新,需要通过help - Install New Software 更新,这种方法随处可见,但我觉得不太合适,因为操作过于繁琐,最终被我发现一个非常简便的方法。

我的理解是,错误主要是由于maven版本和自动生成的POM文件中的maven-jar-plugin版本不匹配,我的工程中,只需要把自动生成的3.0.2版本降级为2.6,即将

<plugin> 
    <artifactId>maven-jar-plugin</artifactId> 
    <version>3.0.2</version> 
</plugin>

更改为

<plugin> 
    <artifactId>maven-jar-plugin</artifactId> 
    <version>2.6</version> 
</plugin>

即可,大家可以根据自己情况更改版本,只要是真实存在的版本号都可以。经过版本降级后,问题就能得到解决。

发布评论

分享到:

IT源码网

微信公众号号:IT虾米 (左侧二维码扫一扫)欢迎添加!

mysql无法启动以及cmd下mysql命令无法识别的讲解
你是第一个吃螃蟹的人
发表评论

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。