自己前些天的项目突然出现这个问题,经过仔细排查,发现有两个原因都会导致这个问题。

第一个就是POM文件中的dependency重复,如果使用的是maven导入,重复写入dependency就会出现该错误。

第二个是版本不匹配,即所引用的jar包太新,并不匹配你的jdk,因为我们正常用的都是jdk7,但是现在已经更新到jdk10了,好多最新版本最新版本的jar包都是基于最新的jdk编写,所以可以将过新的jar包版本降级即可。

发布评论
IT源码网

微信公众号号:IT虾米 (左侧二维码扫一扫)欢迎添加!

POM文件第一行报错org.apache.maven.archiver.MavenArchiver.getManifest讲解
你是第一个吃螃蟹的人
发表评论

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。