前些天学习Strut2,配置环境的时候一直报错,主要遇到两个错误,特此记录,希望能帮助到其他同学。

1.这个错误是由于struts2-core和struts2-convention-plugin 的版本号不匹配,要将它们设为一致。

严重: Exception starting filter struts2 java.lang.InstantiationError: com.opensymphony.xwork2.util.finder.ClassFinder

2. 这个问题则是由于依赖包里没有这个类,很多教程都是用的这个类,然而却运行不起来。这是由于struts2不同版本里,过滤器的名称都不一样,较新版本里过滤器名称是org.apache.struts2.dispatcher.filter.StrutsPrepareAndExecuteFilter,建议可以自己查看一下依赖包里对应的过滤器类名称。

严重: Exception starting filter struts2 java.lang.ClassNotFoundException: org.apache.struts2.dispatcher.FilterDispatcher

 

发布评论

分享到:

IT源码网

微信公众号号:IT虾米 (左侧二维码扫一扫)欢迎添加!

Unsupported major.minor version 52.0 错误解决方法讲解
你是第一个吃螃蟹的人
发表评论

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。